You must be logged in to post messages.
Please login or register

Technical Help
Moderated by Yeebaagooon, TAG

Hop to:    
Welcome! You are not logged in. Please Login or Register.1 reply
Age of Mythology Heaven » Forums » Technical Help » "Error loading aomxailoaader.xs" problem solved
Bottom
Topic Subject:"Error loading aomxailoaader.xs" problem solved
wren9x
Citizen
posted 04 February 2018 07:41 AM EDT (US)         
"cant load blah..aomxailoader" error.

the problem is not that file.
the problem is in the TECHTREEX file.

techtreex.xml, if it has syntax errors, will cause the game make the seemingly unrelated aomxailoader.xs file to barf.

started getting the "cant load blah..aomaxailoader.xs" issue.

so i browsed here and all over, no real solutions.
i knew the aomxailoader.xs wasnt corrupted as i have never touched the file.

since ive been dickering with protox and treex, i decided to
do some testing by inserting gargbage into protox. game failed to load. undid the garbage.
then put garbage into treex. BAM! loader.xs error.

searched through techtreex.xml and lo and behold, i found code that was missing the end tag <\effect>. (i must have fat fingered and deleted accidentally while editing this file.

i repaired the entery, then walah, game loaded, no "blah..loader.xs" error anymore.

the problem is not the aomxailoader.xs file, its in techtreex.xml file. so scour there to find any mistakes. its a huge file so focus on where you remember editing.

hope this helps.
AuthorReplies:
TAG
That AoM Guy
(id: aom expert)
posted 04 February 2018 11:44 AM EDT (US)     1 / 1       
great stuff, will most likely go into our guides section at some point

Check out my YouTube
For live help with me, enter this chatroom. If I'm not on you can leave a message.
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Mythology Heaven | HeavenGames