You must be logged in to post messages.
Please login or register

Scenario Design
Moderated by Yeebaagooon, TAG, nottud

Hop to:    
Welcome! You are not logged in. Please Login or Register.2500 replies, Closed
Age of Mythology Heaven » Forums » Scenario Design » Have a question? Post it here!
Bottom
Topic Subject:Have a question? Post it here!
« Previous Page  1 ··· 10 ··· 20 ··· 30 ··· 40 ··· 48 49 50 51 52 ··· 60 ··· 70 ··· 80 ··· 90 ··· 100  Next Page »
King Jared
Mortal
posted 15 January 2004 10:57 AM EDT (US)         
I, and I'm sure others, have noticed that a lot of forum space is occupied by threads asking questions about the various aspects of Age of Mythology scenario design. So to reduce the space taken up by these question threads in the forum, and to make it a little easier on those who diligently try to answer them all, I started this general question-and-answer thread.

So, post any question regarding triggers, units, mapping, modding... anything related to Age of Mythology, or just life in general, and we, the skilled designers in the AOMH community, will do out best to answer them.

Fire away.

I'm sure you've all noticed by now that the thread has had a quite unexpected level of success, and I see no reason to cut that success short. Keep asking your questions, and we'll keep answering them. I also want to thank all those who've taken it upon themselves to answer any and all questions posted here, namely AoMPlayer000 and oddy, as well as several others. Good work, lads.


Your Divine Overlord
KING JARED
Aw, hell, I dunno, she had some tig-ole-bitties, d'int she?
big.vitt@gmail.com

[This message has been edited by King Jared (edited 04-30-2004 @ 04:27 PM).]

AuthorReplies:
theNodgene1
Mortal
posted 22 August 2004 05:52 AM EDT (US)     1226 / 2500       
The issue isn't the QVs I think, I've got them to randomly place a unit at the start perfectly.
It's the fact, that if you select the "not" option it makes all conditions in the trigger go with a "Not". But then this cancels the QV because 'QV set: QVR1 : 1,2,3,4etc' gets a "not" tag.
So trying to make seperate triggers, a one for the
unit in area: players 2,3,4 (seperate conditions) *NOT*
and one for the QV set's to radomise the thing, even if you put them in any order, QV or not in area first, they won't work as two triggers activating one another because QV with completely randomize where they are placed, and the only way I could think of getting this to work would be to use the trigger as one:
Con:QV set: QVR1: 1,2,3,4etc
Con:Units *not* in area: for enemy players.

The system essentialy is trying to make a random but fair placement for four players, for four points on the map, to ensure there is no combat when the units are randomly placed.
Hmmm...
*Notices QV check... Scraps all that is written.*
Ahhhhh, now that would work... I'll test it soon.

[This message has been edited by TheNodgene1 (edited 08-22-2004 @ 05:55 AM).]

pftq
Mortal
posted 22 August 2004 06:28 AM EDT (US)     1227 / 2500       
Easy solution if I get what you're trying to do: Use Units in Area = 0.

If you want it to not be 0, use => 1. Then you can use the same trigger.

If you don't want players to fight in begin of game, maybe you can make them all neutral in the beginning or something.

[This message has been edited by pftq (edited 08-22-2004 @ 06:29 AM).]

theNodgene1
Mortal
posted 22 August 2004 07:14 AM EDT (US)     1228 / 2500       
A ceasefire at the start, why didn't i think of that
Thank you again pftq!

[This message has been edited by TheNodgene1 (edited 08-22-2004 @ 07:19 AM).]

theNodgene1
Mortal
posted 22 August 2004 07:49 PM EDT (US)     1229 / 2500       
*re-reads the last statement* oh, using 0 units con- now that is pure genious, pftq! Genious, lol.
I think I'll get crackin' with that, I'll give you results soonish.
theNodgene1
Mortal
posted 22 August 2004 08:17 PM EDT (US)     1230 / 2500       
New error, ohh goodey - I think I'll dedicate this sceanrio to you if we get through this, you've helped tons.
Now the problem is this

One of four QVR1
Con:QV check:QVunit1
Con:Units in area:0 (multiplied by three to make the three oposite players, 2,3,4)

Effect: Armydeploy:unit (same area as unit in area con.)

Now it will randomise, and will only do this once, so if the areaa is occupied the trigger wont work, and doesnt refire,
(this trigger does not need to loop)
I have made the triggers for all four players on one choice of unit, and only player4 and 1 as an random example were spawned... Then when I moved my unit away from the area and player2's unit spawned, player3's didnt create.

However, I think I'll just make a movement trigger to move created units away from the spawn area fast enough to allow other ones to spawn, and put in a ceasefire at the start, so the units dont attack, and gives em time to run and take up positions.

[This message has been edited by TheNodgene1 (edited 08-22-2004 @ 08:19 PM).]

pftq
Mortal
posted 22 August 2004 08:27 PM EDT (US)     1231 / 2500       
Wait, let me get this straight. You're trying to deploy a random unit for each player in the same place?

If you only need this once, why do you need the units in area condition?

theNodgene1
Mortal
posted 22 August 2004 08:40 PM EDT (US)     1232 / 2500       
Nonono - ok leme explain
At the start each player (there are 4) picks a unit to deploy, the unit then must deploy at one of 4 locations randomly where there are no other units already! Ok? Helped?
pftq
Mortal
posted 22 August 2004 09:17 PM EDT (US)     1233 / 2500       
Ok sorry, but I really don't understand what is the problem. Isn't four different areas? Why would you need to move units from the area?
theNodgene1
Mortal
posted 22 August 2004 09:37 PM EDT (US)     1234 / 2500       
lol shall i just send you the sceanrio so you can see the issue?
pftq
Mortal
posted 22 August 2004 10:00 PM EDT (US)     1235 / 2500       
fine with me.

again, the email is pftq@sbcglobal.net

[This message has been edited by pftq (edited 08-22-2004 @ 10:00 PM).]

King Jared
Mortal
posted 22 August 2004 11:51 PM EDT (US)     1236 / 2500       
Why isn't this thread sticky anymore? This is an outrage!!

Ah, what do I care, I never help out anymore. Had a good run, though, and is in fact still running. Good job to all those who kept at and keep at the gruesome task of answering all the millions of questions that Age of Mythology spawns. Well done.


Your Divine Overlord
KING JARED
Aw, hell, I dunno, she had some tig-ole-bitties, d'int she?
big.vitt@gmail.com
pftq
Mortal
posted 23 August 2004 06:42 PM EDT (US)     1237 / 2500       
Okay I got yet another one lol.

You know how sometimes when you load a scenario, you start with something selected, but not really selected? More details: It has pic, stats, name and everything but you can't press the space bar to snap to it or tell it to do something.

How do you get rid of that prob? I hate it when some of the hidden objects/surprises in the scen are shown first thing in the game.

Thanks.

theNodgene1
Mortal
posted 23 August 2004 09:52 PM EDT (US)     1238 / 2500       
That's a toughy, is it caused by having the object selected in the editor and saved selected? Just dont select a unit in the editor and it'd work? Just a sugestion,
Out Of Sync
Mortal
posted 23 August 2004 10:38 PM EDT (US)     1239 / 2500       
I Have A Modding Qeustion,

When I Get Into Aomed I Go To My Files, There Is No Data2 Anywhere, So I Do Data And 5 Hours Later Its Still Loading!!!! Is This Because I Don't Have Data2 Or Because It Takes This Long
(If You Could Help Me Get Data2 I Would Be Most Welcomed)

pftq
Mortal
posted 23 August 2004 11:08 PM EDT (US)     1240 / 2500       
It DOES take a long time for AOMED to get the stuff out of Data to answer your question. I have a pretty fast PC and it took me about 5-10 min.

Not sure about Data2. I think only the Titans has it, but I didn't pay attention before the expansion.


@The Nodgene1: I know for sure it's not from saving with something selected The stuff selected is random and different everytime - cin blocks, units, buildings etc.

I tried making sure I didn't select anything already. I even used a clear unit selection effect in the beginning of the game.

Lexus_Reloaded
Mortal
posted 24 August 2004 02:46 AM EDT (US)     1241 / 2500       
The data file is for AOM

The data2 file is for TT


Lexus
Current Designs:
The Silmarillion 5% || Elenamon 75%
The age of Men is over. The time of Orcs has come. Gothmog
oddy
Mortal
posted 24 August 2004 07:19 AM EDT (US)     1242 / 2500       
Well I Think This Capitalization Is Very Interesting.
The data files are not stored in the My Games folder.

A condition is not a trigger.
An effect is not a trigger.
A trigger is a combination of one or more conditions and effects.
It causes effects to happen if and when conditions are met.
Period.
theNodgene1
Mortal
posted 24 August 2004 09:06 AM EDT (US)     1243 / 2500       
I'm sure we can beat the eye candy thread soon, we just need to keep making ambitious projects and asking complex questions

[This message has been edited by TheNodgene1 (edited 08-24-2004 @ 09:06 AM).]

Out Of Sync
Mortal
posted 24 August 2004 11:45 AM EDT (US)     1244 / 2500       
I Play AomTT (Age Of Mythology: The Titans=Data2-Not Found)
Lexus_Reloaded
Mortal
posted 24 August 2004 11:51 AM EDT (US)     1245 / 2500       
It is not in My Games folder but in Program Files, Microsoft Games, AOM, Data.

Lexus
Current Designs:
The Silmarillion 5% || Elenamon 75%
The age of Men is over. The time of Orcs has come. Gothmog
CreamPuff
Mortal
posted 24 August 2004 12:44 PM EDT (US)     1246 / 2500       
I have 2 questions:

1) I'm having serious trouble making my first cinematic (and yes, i already looked through the library). I place my 1st way point, fine, zoom out and place my 2nd way point, still fine. I play it and it looks fine. I rotate th camra slightly and plac the 3rd way point. Now, whn i play it, the camera goes all over the place!! Dos anyonw know what's going on?

2)Sometimes when I playtest my scenario and try to return to the editor, it brings mt to the main menu. It's really annoying, because if i don;'t save everytime before playtsting, i lose evrything i just did.

Thanks for any hlp.

AoMPlayer000
Banned
posted 24 August 2004 01:00 PM EDT (US)     1247 / 2500       
1) Yes, I know what's going on; the camera track editor is a bit crappy sometimes . You have to adjust your third waypoint elaborately and add more points in between the second and the third. I personally always try to hold the number of waypoints down to optionally two (or three), because the more they get, the more likely it is that the track gets messed up.

2) Didn't encounter this bug yet. If you use the NXE, contact reyk.

LJC
Mortal
posted 24 August 2004 03:58 PM EDT (US)     1248 / 2500       
Ok i have a question.

Im trying to create a free roming world in which there is one main map,and four mini maps branched off the main.One for each corner.

My question is,can i branch more than one scenario into one map?
So you have a choice of four places to advance to different scenarios ?


(¯`-.:=LJC=:.-´¯)
|Member of|Ambition Designs| & |TOAO Clan|
|Download|The Greek Dream|
|Check|F.A.Q|
pftq
Mortal
posted 24 August 2004 04:58 PM EDT (US)     1249 / 2500       
Well, if I did that, I'd make it so everytime the player's main unit goes to a certain corner, you load a certain scenario. But then you'd start over. All your progress would be lost.
LJC
Mortal
posted 24 August 2004 04:59 PM EDT (US)     1250 / 2500       
Thats what i want.

(¯`-.:=LJC=:.-´¯)
|Member of|Ambition Designs| & |TOAO Clan|
|Download|The Greek Dream|
|Check|F.A.Q|
« Previous Page  1 ··· 10 ··· 20 ··· 30 ··· 40 ··· 48 49 50 51 52 ··· 60 ··· 70 ··· 80 ··· 90 ··· 100  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Mythology Heaven | HeavenGames