You must be logged in to post messages.
Please login or register

Scenario Design
Moderated by Yeebaagooon, nottud

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Have a Question? Post it here!
« Previous Page  1 ··· 10 ··· 20 ··· 29 30 31 32 33 ··· 35  Next Page »
posted 28 September 2015 03:38 PM EDT (US)   



Got a question? Need an answer?
Here is a list of common questions concerning AoM.





FAQ


Upon playtesting a scenario in the editor, I lose within the first five seconds!
Easy to fix. Simply click on the "Scenario" tab in the editor, click on "Scenario Data" and uncheck the check box next to "Use victory conditions". Alternatively, you can place a unit of yours somewhere on the map, then place an enemy unit somewhere else on the map as well.

How come it seems like some units are missing in the list of protounits on a trigger?
To find out the proto name of a unit, have it selected in the editor and click on the "Cinematics" tab, then click "View animations." For a shortcut, just select the unit and press Alt+A.

How do I make units larger or smaller?
This is for The Titans users only. To enlarge a unit, select it and hold "K" on your keyboard. To make the unit smaller, hold "Shift + K".

How can I change the stats (attack/health/etc.) for a unit?
Easy. If you're a Titans user you can find the two triggers called "Modify Protounit" and "Set Tech Status". If you're running regular AoM, you will only have "Set Tech Status" available. You can set unit attributes with both these triggers.

How can I make units regenerate health?
First create a new trigger. Check the Active and Loop boxes. Pull the Priority cursor all the way to the right. Create a new condition Is Alive, select and set your desired unit. Add a condition Timer with a value of 1. Finally, add a Damage Unit effect, select your desired unit again and set the value to -1.

How can I have over 300 population?
Use the Modify Protounit effect to make a protounit have a population cost of a very extremely high number, like 999999999.0 . Make sure that it is a protounit that you can't normally get in-game by yourself. Then just place two of them somewhere on the map, and they will make the population for that player go to a negative number, and be infinite.

My triggers have stopped working!
Using Run immediately, quotations in chats, linking camera tracks, sound timers and decimals in conditions like timer and distance to unit affect this. If you are unsure about what the source is, outline what you did, and we can help.

The computer players aren't acting like computer players should!
You need to set AI for them. In the editor, click the "Scenario" tab, then "Player Data". There will be a button all the way to the right of the player slot to set the AI. It is reccomended you choose one of the "default" ais such as aomdefaultai.xs for AoM Vanilla, or aomxdefaultai.xs for The Titans.

I've seen people do these crazy camera angles that I can't seem to figure out how to do! Help!
A common question. Your camera must be unlocked and working first. It should be already by default. If it's not, press "Shift + Alt + C" to unlock it. To change the pitch of the camera, press "A" and "Z" or "Ctrl + Up Arrow" and "Ctrl + Down Arrow" on your keyboard to go up and down.

How do I add sound and dialogs in a scenario?
Like the dialogs in the campaigns, you can use the trigger effect "Play Dialog" to display text while on Cinematic Mode. You can type a text, include a sound, and a small image (portrait) "Sound filename" is a similar trigger effect, but not the main one used.

How can I give units animations like they do in the campaigns?
Select the unit in the editor, click on the "Cinematics" tab, then click "View animations." In the "Type" tab, find and click "Cinematic". In the "Anim Path:" tab is a list of animations that you can view for sampling. When you find the one you want, you can use its name with the "Set animation" trigger effect and be able to use it in-game.

Practical Guides
Scenario Design Library Articles
Scenario Design Dictionary
Shuch_ya_mouf's Ultimate Trigger Guide
Paperfriend's List of Guides
Making Quality Scenarios: Triggers
Making Quality Scenarios: Eyecandy
Nottud's Guide to the transform trigger
Campaign Dialogue List

Thread credits: Paperfriend + Yeebaago0on (FAQ), Eurotool (design), CeaseDaFire (maintenance), Reach (OP) 


Out Reach
The guy who writes the erotic fan fiction in Yeebaagoon's signature

[This message has been edited by Out Reach (edited 01-22-2019 @ 10:12 AM).]

Replies:
posted 03 April 2020 10:08 AM EDT (US)     751 / 870  
ONly issue with that is it is like a chose your hero type deal...and the unit is on unwalkable terrain. So nothing I did movement wise affects him....which makes it more frustrating because he shouldnt be able to move...it's weird it is only that one spot.

Even stranger still...when I test the cinematic just for his appearance, he is facing forward. but when I test the full game of what i have so far then he is looking the wrong way.

update:

I tried using Army heading but that only worked for after the cinematic finished. Even worse still it seems the more I test the scenario the more messed up it gets. Now the camera track for that specific character is not working either. I tried deleting it and recapturing the shots...no luck. Again I deleted all of that characters triggers and re did it...but now the camera track wont even run. I just don't get it, how can it do something different every time and progressively get worse when all my triggers are pretty much sound?

[This message has been edited by FouadFaraj (edited 04-03-2020 @ 11:29 AM).]

posted 03 April 2020 02:53 PM EDT (US)     752 / 870  
Did you use the Build Cinematic feature from the File tab?

posted 03 April 2020 06:57 PM EDT (US)     753 / 870  
Forgiveness, but I am not sure what you mean by that? I made the cinematic using the camera tool and trigger tool.
posted 04 April 2020 01:00 AM EDT (US)     754 / 870  
He might be getting attacked by something. Alternatively, the AI may have tried to move him.

[This message has been edited by Zenophobia (edited 02-29-2094 @ 10:60 AM).]
posted 04 April 2020 04:30 PM EDT (US)     755 / 870  
That was my first hunch but seems unlikely based on the scenario. Still a possibility.

posted 04 April 2020 09:31 PM EDT (US)     756 / 870  
There could be a chance actually that he is getting attacked...so i made him an ally to the possible attacker....however, I still can see if it is working or not because the camera track is no longer working for him...no matter what I do.
posted 04 April 2020 10:12 PM EDT (US)     757 / 870  
email me the scenario

posted 05 April 2020 01:26 PM EDT (US)     758 / 870  
Sent it! Thank you!
posted 06 April 2020 07:24 PM EDT (US)     759 / 870  
So, he's attacking the shrunken lighthouse that you have there. I did the pandoras box cheat until i got vision and invoked it near the area and saw him attacking it.

As for the camera track it has no duration (time), it's at 0.0000. Needs a length.

[This message has been edited by TAG (edited 04-06-2020 @ 07:25 PM).]

posted 09 April 2020 08:45 PM EDT (US)     760 / 870  
Again just wanted to say thanks...haha such an obvious little mistake making for such a frustration! XD
posted 12 April 2020 09:13 PM EDT (US)     761 / 870  
OK, so one more little issue here...its not big, hopefully an easy fix. But I decided it would be easier for me to finish this scenario using nottud's ultimate super pack. But ever since I installed it. After a cinematic a black line appears and never goes away. It isnt just for custom scenarios either. It is happening as I play the campaign as well. Anyone encounter this or know of a fix?

I am trying to share a picture for an example but I can't figure it out XD

sorry ultra green here at all things tech!
posted 12 April 2020 10:40 PM EDT (US)     762 / 870  
If you are using it for EE I recommend instead you use this: https://steamcommunity.com/sharedfiles/filedetails/?id=1941668366

The original superpack is not properly compatible with EE.
posted 12 April 2020 11:14 PM EDT (US)     763 / 870  
Much appreciated! =)
posted 19 April 2020 00:22 AM EDT (US)     764 / 870  
Ok so I initially posted this question in technical help...but it doesnt seem that thread is as actively answered as this...and my issues seems connected to custom made scenarios anyway...so heres the current issue.

My game crashes anytime I try to play a custom made scenario. Within an average of 5- 10 minutes. Many answers seem to revolve around updating the graphics driver. However, When I go to update it, I navigate to Device Manager. Then find my graphic driver and click automatically search for updates. It then tells me I am running the most recent update. My computer is old,and doesn't have a good graphics card to begin with, but AOM isn't really the most taxing on graphics, right? It worked fine back in the day haha.

Next They mention to remove all mods...I was sad to do so but I tried this...but no luck.

I can play through any of the game with no issue...I have had some bugs during campaign. Specifically with cinematic camera angles. Sometimes I was stuck staring at a blank screen or a wall that blocked the cinematic. But I was able to play through all the campaign modes. The CHiniese campaign skipped and was bugged in the final scene....pretty depressing, but I was able to play.

I can't get within any longer than 5 or 10 minutes of a custom made scenario before the game completely crashes. I thought maybe I made the map too big...so I tried a smaller map...and still no dice.

Is my computer just too old?

System info:

Os- Windows 10

Manufacturer - Lenovo
Model- 80TV
Processor- Intel Core i7-7500U CPU 2.70GHz, 2901 Mhz, 2 cores,4 logical processor
Display adapter - Intel HD Graphics 620

I don't know if this is enough info but my understanding of tech is very limited to begin with haha.

Anyways...im not sure what to do.
posted 19 April 2020 01:10 AM EDT (US)     765 / 870  
What scenarios are you playing in particular? Some of the older ones might not work on the Extended Edition.

[This message has been edited by Zenophobia (edited 02-29-2094 @ 10:60 AM).]
posted 19 April 2020 12:34 PM EDT (US)     766 / 870  
Oh, right sorry...they are actually ones that I have made myself, over the last few months. They work fine up until the game just stops.
posted 19 April 2020 04:56 PM EDT (US)     767 / 870  
Might be using some triggers that are causing a memory leak - are they are custom triggers being used?
posted 19 April 2020 08:15 PM EDT (US)     768 / 870  
Oh...yea actually. I am using 1 custom trigger. It is modify all protounits or something like that...I don't think that was a standard trigger.
posted 20 April 2020 08:51 AM EDT (US)     769 / 870  
Avoid using special characters in text fields.

If you want, you can email me the scenario and I'll tell you what I think is causing the crash, if not the characters.

posted 26 April 2020 00:47 AM EDT (US)     770 / 870  
First question in a very long time, can one modify the attack values on Osiris? If so, how, it doesn't seem his attacks (listed as 5000 hack pierce and crush dmg) are modified by any of the modify ranged or melee protounit hack pierce or crush values.

Also, i recall someone (probably nottud?) wrote a modify protounit absolute trigger (that would assign a protounit a specific stat value rather than adjusting from an existing base) I don't appear to have those in my install anymore. Where can I download them or can they be provided here?

Hope you are all well.

"I NED MOAR RANGE" Pubby8
posted 26 April 2020 02:16 AM EDT (US)     771 / 870  
can one modify the attack values on Osiris?
I think you can't modify the attack of Osiris, Son of Osiris and Statues of Lightning (do you notice a theme?) using modify protounit. I seem to remember some discussion about a trigger that could do it but I can not find it.
Also, i recall someone (probably nottud?) wrote a modify protounit absolute trigger (that would assign a protounit a specific stat value rather than adjusting from an existing base) I don't appear to have those in my install anymore. Where can I download them or can they be provided here?
Yes, Nottud wrote a trigger. See the link below for more information.
https://aom.heavengames.com/cgi-bin/forums/display.cgi?action=ct&f=13,30046,0,all

Nice to have you back, are you entering the scenario design competition?
posted 26 April 2020 05:02 AM EDT (US)     772 / 870  
I think you can't modify the attack of Osiris, Son of Osiris and Statues of Lightning (do you notice a theme?) using modify protounit. I seem to remember some discussion about a trigger that could do it but I can not find it.
Only works in the first unit it attacks, the rest have the standard chain lightning damage.
<Effect name="Increase SoO Attack">
<Param name="SrcObject" dispName="$$22295$$Source Units" VarType="unit">default</Param>
<Param name="PlayerID" dispName="$$22301$$Player" varType="string">1</Param>
<Param name="DeltaAttack" dispName="Delta" VarType="long">0</Param>
<Command>xsSetRuleMinIntervalSelf(3); //attack animation length</Command>
<Command>xsSetContextPlayer(%PlayerID%);</Command>
<Command>for(unitID=0;>1) {} unitID=kbGetBlockID("%SrcObject%");</Command>
<Command>for(actionID=0;>1) {} actionID=kbUnitGetActionType(unitID);</Command>
<Command>if(actionID != 59) return; //lightning attack</Command>
<Command>for(targetID=0;>1) {} targetID=kbUnitGetTargetUnitID(unitID);</Command>
<Command>trQuestVarSet("QVThatHoldsTheAttack", ŞltaAttack% * (1.0-0.25));</Command>
<Command>trUnitSelectClear();</Command>
<Command>trUnitSelectByID(targetID);</Command>
<Command>trDamageUnit(trQuestVarGet("QVThatHoldsTheAttack"));</Command>
<Command>} //end this effect</Command>
<Command>} //end this trigger</Command>
<Command>rule _SomeAnnoyingCommands</Command>
<Command>inactive</Command>
<Command>{</Command>
<Command>if (false) {</Command>
</Effect>

______________________________________ Yeebaagooon ______________________________________
____________________ AoMH Seraph ____________________
"You can't trust yeebaagooon to lead a rebelion, He would send everyone to steal mirrors so he could bask in his own brilliance." - Out Reach
"Yeebaagooon had never seen a more handsome man in all his life. He couldn't control himself, He needed to act. Gripping the mirror in his strong arms he kissed the figure before him..." - Out Reach
AoMH: Unfinished Scenarios|Singleplayer: Codename Ripto|Multiplayer: Minigames Z|CSC 7
Ex Seraphs Dictator, Spore Heaven Seraph
posted 26 April 2020 08:35 AM EDT (US)     773 / 870  
Where did you find that Yeeb?
posted 26 April 2020 08:54 AM EDT (US)     774 / 870  
<Command>trQuestVarSet("QVThatHoldsTheAttack", ŞltaAttack% * (1.0-0.25));</Command>
This line has corrupted.

[This message has been edited by nottud (edited 04-26-2020 @ 08:54 AM).]

posted 26 April 2020 04:08 PM EDT (US)     775 / 870  
Tag, thanks for the response, I thought I answered but I guess it didn't go through. I removed the custom trigger and everything was fine =)

sadly I have a new issue now...I guess my nickname should be "the problem child" haha

Out of the blue I can no longer use the "Sound file name" trigger. I go to click on the one I want and it never pastes into the field. I tried doubling clicking to add, and clicking open but it remains blank. So I figured, Ill type it in manually. and it still doesnt work.

I thought, maybe some of my mods are interrupting, although it seemed unlikely, the only mod I use for editor is the advance editor V2. But anyway I disabled all mods but the advanced editor and no luck...so I even disabled the advance editor and still no luck.

Any thoughts?
« Previous Page  1 ··· 10 ··· 20 ··· 29 30 31 32 33 ··· 35  Next Page »
Age of Mythology Heaven » Forums » Scenario Design » Have a Question? Post it here!
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Age of Mythology Heaven | HeavenGames